GLSA-201701-11 : musl: Integer overflow

critical Nessus Plugin ID 96242

Synopsis

The remote Gentoo host is missing one or more security-related patches.

Description

The remote host is affected by the vulnerability described in GLSA-201701-11 (musl: Integer overflow)

A vulnerability was discovered in musl’s tre_tnfa_run_parallel function buffer overflow logic, due to the incorrect use of integer types and missing overflow checks.
Impact :

An attacker, who controls the regular expression and/or string being searched, could execute arbitrary code with the privileges of the process.
Workaround :

There is no known workaround at this time.

Solution

All musl users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=sys-libs/musl-1.1.15-r2'

See Also

https://security.gentoo.org/glsa/201701-11

Plugin Details

Severity: Critical

ID: 96242

File Name: gentoo_GLSA-201701-11.nasl

Version: 3.4

Type: local

Published: 1/3/2017

Updated: 1/11/2021

Risk Information

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: High

Base Score: 7.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

CVSS v3

Risk Factor: Critical

Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:musl, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 1/2/2017

Reference Information

CVE: CVE-2016-8859

GLSA: 201701-11