GLSA-201701-05 : BusyBox: Denial of Service

High Nessus Plugin ID 96236


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-201701-05 (BusyBox: Denial of Service)

The recv_and_process_client_pkt function in networking/ntpd.c in BusyBox allows remote attackers to cause a Denial of Service (CPU and bandwidth consumption) via a forged NTP packet, which triggers a communication loop.
Impact :

A remote attacker might send a specially crafted package to a machine running BusyBox ntpd, possibly resulting in a Denial of Service condition.
Workaround :

There is no known workaround at this time.


All BusyBox users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=sys-apps/busybox-1.25.1'

See Also

Plugin Details

Severity: High

ID: 96236

File Name: gentoo_GLSA-201701-05.nasl

Version: $Revision: 3.1 $

Type: local

Published: 2017/01/03

Modified: 2017/01/03

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C


Base Score: 7.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:busybox, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2017/01/01

Reference Information

CVE: CVE-2016-6301

GLSA: 201701-05