GLSA-201612-52 : Pillow: Multiple vulnerabilities

Critical Nessus Plugin ID 96227


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-201612-52 (Pillow: Multiple vulnerabilities)

Multiple vulnerabilities have been discovered in Pillow. Please review the CVE identifiers referenced below for details.
Impact :

A local attacker could perform symlink attacks to overwrite arbitrary files with the privileges of the user running the application, or obtain sensitive information.
A remote attackers could execute arbitrary code with the privileges of the process, or cause a Denial of Service condition.
Workaround :

There is no known workaround at this time.


All Pillow users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=dev-python/pillow-3.4.2'

See Also

Plugin Details

Severity: Critical

ID: 96227

File Name: gentoo_GLSA-201612-52.nasl

Version: $Revision: 3.1 $

Type: local

Published: 2017/01/03

Modified: 2017/01/03

Dependencies: 12634

Risk Information

Risk Factor: Critical


Base Score: 10

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C


Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:pillow, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2016/12/31

Reference Information

CVE: CVE-2014-1932, CVE-2014-1933, CVE-2016-0740, CVE-2016-0775, CVE-2016-2533, CVE-2016-4009, CVE-2016-9189, CVE-2016-9190

GLSA: 201612-52