NVIDIA Linux GPU Display Driver 304.x < 304.134 / 340.x < 340.101 / 361.x < 361.107 / 375.x < 375.26 GPU Interrupt Saturation DoS

Medium Nessus Plugin ID 96001


A display driver installed on the remote Linux host is affected by a denial of service vulnerability.


The version of the NVIDIA GPU display driver installed on the remote Linux host is 304.x prior to 304.134, 340.x prior to 340.101, 361.x prior to 361.107 (Tesla P100), 375.x prior to 375.20 (Tesla P100), or 375.x prior to 370.26. It is, therefore, affected by a denial of service vulnerability due to a flaw in the kernel mode layer (nvidia.ko) driver. A local attacker can exploit this to cause GPU interrupt saturation, resulting in a denial of service condition.


Upgrade the NVIDIA graphics driver to version 304.134 / 340.101 / 361.107 / 375.20 (Tesla P100 Series) / 375.26 or later in accordance with the vendor advisory.

See Also


Plugin Details

Severity: Medium

ID: 96001

File Name: nvidia_unix_cve_2016_8826.nasl

Version: $Revision: 1.4 $

Type: local

Family: Misc.

Published: 2016/12/21

Modified: 2017/02/27

Dependencies: 72481

Risk Information

Risk Factor: Medium


Base Score: 4.9

Temporal Score: 3.6

Vector: CVSS2#AV:L/AC:L/Au:N/C:N/I:N/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C


Base Score: 5.5

Temporal Score: 4.8

Vector: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:nvidia:gpu_driver

Required KB Items: NVIDIA_UNIX_Driver/Version

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2016/12/09

Vulnerability Publication Date: 2016/12/09

Reference Information

CVE: CVE-2016-8826

BID: 94957

OSVDB: 148773