Cisco AnyConnect Secure Mobility Client 3.1.x < 4.3.4019.0 / 4.4.x < Privilege Escalation

High Nessus Plugin ID 95951


A VPN application installed on the remote host is affected by a privilege escalation vulnerability.


The version of Cisco AnyConnect Secure Mobility Client installed on the remote Windows host is 3.x or 4.x prior to 4.3.4019.0 or 4.4.x prior to It is, therefore, affected by a privilege escalation vulnerability due to incorrect permissions of a system directory at installation time. A local attacker can exploit this, by creating a specially crafted interprocess communication (IPC) to the virtual private network (VPN) agent process, to execute commands on the host with elevated system level privileges.


Upgrade to Cisco AnyConnect Secure Mobility Client version 4.3.4019.0 / or later.

See Also

Plugin Details

Severity: High

ID: 95951

File Name: cisco_anyconnect_CSCvb68043.nasl

Version: $Revision: 1.2 $

Type: local

Agent: windows

Family: Windows

Published: 2016/12/20

Modified: 2016/12/21

Dependencies: 54953

Risk Information

Risk Factor: High


Base Score: 7.2

Temporal Score: 5.3

Vector: CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C


Base Score: 7.8

Temporal Score: 6.8

Vector: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:cisco:anyconnect_secure_mobility_client

Required KB Items: installed_sw/Cisco AnyConnect Secure Mobility Client, SMB/Registry/Enumerated

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2016/12/07

Vulnerability Publication Date: 2016/12/07

Reference Information

CVE: CVE-2016-9192

BID: 94770

OSVDB: 148319

CISCO-SA: cisco-sa-20161207-anyconnect1