Asterisk Opus Codec DoS (AST-2016-008)

High Nessus Plugin ID 95926


A telephony application running on the remote host is affected by a denial of service vulnerability.


According to its SIP banner, the version of Asterisk running on the remote host is 13.12.x prior to 13.13.1 or 14.x prior to 14.2.1. It is, therefore, affected by a denial of service vulnerability in the Opus codec when handling SDP offer or answer requests due to improper parsing of format parameters when they are separated by space characters. An unauthenticated, remote attacker can exploit this, via a specially crafted request, to cause the parser to recursively call itself until it crashes.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.


Upgrade to Asterisk version 13.13.1 / 14.2.1 or later.

See Also

Plugin Details

Severity: High

ID: 95926

File Name: asterisk_ast_2016_008.nasl

Version: $Revision: 1.5 $

Type: remote

Family: Misc.

Published: 2016/12/19

Modified: 2017/04/07

Dependencies: 63202

Risk Information

Risk Factor: High


Base Score: 7.8

Temporal Score: 6.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:ND


Base Score: 7.5

Temporal Score: 6.9

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:X

Vulnerability Information

CPE: cpe:/a:digium:asterisk

Required KB Items: asterisk/sip_detected, Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2016/12/08

Vulnerability Publication Date: 2016/12/08

Reference Information

CVE: CVE-2016-9937

BID: 94792

OSVDB: 148460