Apache ActiveMQ 5.x < 5.14.2 Web-based Administration Console Unspecified XSS

medium Nessus Plugin ID 95920


The remote host is running a web application that is affected by a cross-site scripting vulnerability.


The version of Apache ActiveMQ running on the remote host is 5.x prior to 5.14.2. It is, therefore, affected by a cross-site scripting (XSS) vulnerability in the web-based administration console due to improper validation of user-supplied input. An unauthenticated, remote attacker can exploit this, by convincing a user to follow a specially crafted link, to execute arbitrary script code in a user's browser session.


Upgrade to Apache ActiveMQ version 5.14.2 or later.

See Also


Plugin Details

Severity: Medium

ID: 95920

File Name: activemq_5_14_2.nasl

Version: 1.11

Type: combined

Agent: unix

Family: CGI abuses

Published: 12/16/2016

Updated: 6/6/2024

Configuration: Enable thorough checks

Supported Sensors: Nessus Agent, Nessus

Enable CGI Scanning: true

Risk Information


Risk Factor: Low

Score: 3.0


Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.6

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

CVSS Score Source: CVE-2016-6810


Risk Factor: Medium

Base Score: 6.1

Temporal Score: 5.7

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:X

Vulnerability Information

CPE: cpe:/a:apache:activemq

Required KB Items: installed_sw/Apache ActiveMQ

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 12/9/2016

Vulnerability Publication Date: 12/9/2016

Reference Information

CVE: CVE-2016-6810

BID: 94882