Joomla! < 3.6.5 Multiple Vulnerabilities

High Nessus Plugin ID 95916

Synopsis

The remote web server contains a PHP application that is affected by multiple vulnerabilities.

Description

According to its self-reported version number, the Joomla! installation running on the remote web server is prior to 3.6.5. It is, therefore, affected by multiple vulnerabilities :

- A flaw exists in the JFilterInput::isFileSafe() function due to improper validation of file types and extensions of uploaded files before placing them in a user-accessible path. An unauthenticated, remote attacker can exploit this issue, by uploading a specially crafted file using an alternative PHP extension and then requesting it, to execute arbitrary code with the privileges of the web service. Note that this issue affects versions 3.0.0 to 3.6.4.
(CVE-2016-9836)

- An information disclosure vulnerability exists in the Beez3 com_content article layout override due to inadequate access control list (ACL) checks. An authenticated, remote attacker can exploit this to disclose restricted content. Note that this issue affects versions 3.0.0 to 3.6.4. (CVE-2016-9837)

- A privilege escalation vulnerability exists due to improper validation of form data before storing it in the session. An authenticated, remote attacker can exploit this, via a specially crafted request, to modify existing user accounts, such as resetting credentials or group assignments. (CVE-2016-9838)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Joomla! version 3.6.5 or later.

See Also

http://www.nessus.org/u?3ca7356f

http://www.nessus.org/u?7934a324

http://www.nessus.org/u?6c4c5a5e

http://www.nessus.org/u?a397aea4

Plugin Details

Severity: High

ID: 95916

File Name: joomla_365.nasl

Version: 1.7

Type: remote

Family: CGI abuses

Published: 2016/12/16

Updated: 2018/06/14

Dependencies: 21142

Configuration: Enable paranoid mode

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Temporal Score: 7.1

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:U/RC:ND

CVSS v3.0

Base Score: 8.8

Temporal Score: 8.5

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:F/RL:U/RC:X

Vulnerability Information

CPE: cpe:/a:joomla:joomla\!

Required KB Items: installed_sw/Joomla!, www/PHP, Settings/ParanoidReport

Patch Publication Date: 2016/12/13

Vulnerability Publication Date: 2016/10/27

Reference Information

CVE: CVE-2016-9836, CVE-2016-9837, CVE-2016-9838

BID: 94663, 94892, 94893