Apache Struts 2.5.x < 2.5.8 URLValidator Form Field Handling Remote DoS

Medium Nessus Plugin ID 95887


The remote Windows host contains a web application that uses a Java framework that is affected by a denial of service vulnerability.


The version of Apache Struts running on the remote Windows host is 2.5.x prior to 2.5.8. It is, therefore, potentially affected by a denial of service vulnerability in the URLValidator class due to improper handling of user-supplied input to the form field. An unauthenticated, remote attacker can exploit this, via a specially crafted URL, to overload server processes.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.


Upgrade to Apache Struts version 2.5.8 or later. Alternatively, apply the workaround referenced in the vendor advisory.

See Also



Plugin Details

Severity: Medium

ID: 95887

File Name: struts_2_5_8_win_local.nasl

Version: $Revision: 1.3 $

Type: local

Agent: windows

Family: Windows

Published: 2016/12/15

Modified: 2017/03/20

Dependencies: 73943

Risk Information

Risk Factor: Medium


Base Score: 5

Temporal Score: 4.1

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:ND


Base Score: 7.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Vulnerability Information

CPE: cpe:/a:apache:struts

Required KB Items: installed_sw/Apache Struts, Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2016/11/23

Vulnerability Publication Date: 2016/11/23

Reference Information

CVE: CVE-2016-8738

BID: 94657

OSVDB: 147960