GLSA-201612-43 : Node.js: Multiple vulnerabilities

Medium Nessus Plugin ID 95817


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-201612-43 (Node.js: Multiple vulnerabilities)

Multiple vulnerabilities have been discovered in Node.js. Please review the CVE identifiers referenced below for details.
Impact :

A remote attacker could possibly cause a Denial of Service condition, or conduct man-in-the-middle attacks.
Workaround :

There is no known workaround at this time.


All Node.js 0.12.x users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=net-libs/nodejs-0.12.17' All Node.js 4.6.x users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=net-libs/nodejs-4.6.1'

See Also

Plugin Details

Severity: Medium

ID: 95817

File Name: gentoo_GLSA-201612-43.nasl

Version: $Revision: 2.1 $

Type: local

Published: 2016/12/14

Modified: 2016/12/14

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P


Base Score: 7.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:nodejs, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2016/12/13

Reference Information

CVE: CVE-2015-8027, CVE-2016-2086, CVE-2016-2216, CVE-2016-5325

GLSA: 201612-43