GLSA-201612-41 : WebKitGTK+: Multiple vulnerabilities

Medium Nessus Plugin ID 95815


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-201612-41 (WebKitGTK+: Multiple vulnerabilities)

Multiple vulnerabilities have been discovered in WebKitGTK+. Please review the CVE identifiers referenced below for details.
Impact :

A remote attacker can use multiple vectors to execute arbitrary code or cause a Denial of Service condition.
Workaround :

There is no known workaround at this time.


All WebKitGTK+ users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=net-libs/webkit-gtk-2.4.10-r200'

See Also

Plugin Details

Severity: Medium

ID: 95815

File Name: gentoo_GLSA-201612-41.nasl

Version: $Revision: 2.1 $

Type: local

Published: 2016/12/14

Modified: 2016/12/14

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:webkit-gtk, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2016/12/13

Reference Information

CVE: CVE-2014-4412, CVE-2014-4413, CVE-2014-4414

GLSA: 201612-41