GLSA-201612-40 : SQUASHFS: Multiple vulnerabilities

Medium Nessus Plugin ID 95743


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-201612-40 (SQUASHFS: Multiple vulnerabilities)

Multiple vulnerabilities have been discovered in SQUASHFS. Please review the CVE identifiers referenced below for details.
Impact :

A remote attacker could entice a user to open a specially crafted .sqsh file using unsquashfs; possibly resulting in the execution of arbitrary code with the privileges of the process, or a Denial of Service condition.
Workaround :

There is no known workaround at this time.


All squashfs-tools users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=sys-fs/squashfs-tools-4.3'

See Also

Plugin Details

Severity: Medium

ID: 95743

File Name: gentoo_GLSA-201612-40.nasl

Version: $Revision: 3.2 $

Type: local

Published: 2016/12/13

Modified: 2016/12/14

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:squashfs-tools, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2016/12/13

Reference Information

CVE: CVE-2012-4024, CVE-2012-4025

GLSA: 201612-40