GLSA-201612-35 : XStream: Remote execution of arbitrary code

High Nessus Plugin ID 95738

Synopsis

The remote Gentoo host is missing one or more security-related patches.

Description

The remote host is affected by the vulnerability described in GLSA-201612-35 (XStream: Remote execution of arbitrary code)

It was found that XStream would deserialize arbitrary user-supplied XML content, thus representing objects of any type.
Impact :

A remote attacker could pass a specially crafted XML document to XStream, possibly resulting in the execution of arbitrary code with the privileges of the process or a Denial of Service condition.
Workaround :

There is no known workaround at this time.

Solution

All XStream users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=dev-java/xstream-1.4.8-r1'

See Also

https://security.gentoo.org/glsa/201612-35

Plugin Details

Severity: High

ID: 95738

File Name: gentoo_GLSA-201612-35.nasl

Version: 3.4

Type: local

Published: 2016/12/13

Updated: 2019/05/17

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

CVSS v3.0

Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:xstream, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2016/12/13

Vulnerability Publication Date: 2019/05/15

Reference Information

CVE: CVE-2013-7285

GLSA: 201612-35