GLSA-201612-15 : ARJ: Multiple vulnerabilities

High Nessus Plugin ID 95548

Synopsis

The remote Gentoo host is missing one or more security-related patches.

Description

The remote host is affected by the vulnerability described in GLSA-201612-15 (ARJ: Multiple vulnerabilities)

Multiple vulnerabilities have been discovered in ARJ. Please review the CVE identifiers referenced below for details.
Impact :

An attacker, using a specially crafted ARJ archive, could possibly execute arbitrary code with the privileges of the process, or cause a Denial of Service condition.
Workaround :

There is no known workaround at this time.

Solution

All ARJ users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=app-arch/arj-3.10.22-r5'

See Also

https://security.gentoo.org/glsa/201612-15

Plugin Details

Severity: High

ID: 95548

File Name: gentoo_GLSA-201612-15.nasl

Version: Revision: 2.1

Type: local

Published: 2016/12/06

Updated: 2016/12/06

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:arj, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2016/12/06

Reference Information

CVE: CVE-2015-0556, CVE-2015-0557, CVE-2015-2782

GLSA: 201612-15