GLSA-201612-07 : dpkg: Arbitrary code execution

High Nessus Plugin ID 95522


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-201612-07 (dpkg: Arbitrary code execution)

Gentoo Linux developer, Hanno Böck, discovered an off-by-one error in the dpkg-deb component of dpkg, the Debian package management system, which triggers a stack-based buffer overflow.
Impact :

An attacker could potentially execute arbitrary code if an user or an automated system were tricked into processing a specially crafted Debian binary package (.deb).
Workaround :

There is no known workaround at this time.


All dpkg users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=app-arch/dpkg-1.17.26'

See Also

Plugin Details

Severity: High

ID: 95522

File Name: gentoo_GLSA-201612-07.nasl

Version: $Revision: 3.1 $

Type: local

Published: 2016/12/05

Modified: 2016/12/05

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:dpkg, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2016/12/04

Reference Information

CVE: CVE-2015-0860

GLSA: 201612-07