ImageMagick 7.x < 7.0.3-6 WaveletDenoiseImage() Heap Buffer Overflow RCE

High Nessus Plugin ID 95319


An application installed on the remote Windows host is affected by a remote code execution vulnerability.


The version of ImageMagick installed on the remote Windows host is 7.x prior to 7.0.3-6. It is, therefore, affected by a heap buffer overflow condition in the WaveletDenoiseImage() function within file MagicCore/fx.c. An unauthenticated, remote attacker can exploit this to cause a denial of service condition or the execution of arbitrary code.


Upgrade to ImageMagick version 7.0.3-6 or later. Note that you may also need to manually uninstall the vulnerable version from the system.

See Also

Plugin Details

Severity: High

ID: 95319

File Name: imagemagick_7_0_3_6.nasl

Version: $Revision: 1.3 $

Type: local

Agent: windows

Family: Windows

Published: 2016/11/25

Modified: 2017/03/22

Dependencies: 38949

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 6.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C


Base Score: 8.1

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: cpe:/a:imagemagick:imagemagick

Required KB Items: installed_sw/ImageMagick

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2016/11/08

Vulnerability Publication Date: 2016/10/31

Reference Information

CVE: CVE-2016-9298

BID: 94310

OSVDB: 147304