Drupal 7.x < 7.52 / 8.x < 8.2.3 Multiple Vulnerabilities

Medium Nessus Plugin ID 95026

New! Vulnerability Priority Rating (VPR)

Tenable calculates a dynamic VPR for every vulnerability. VPR combines vulnerability information with threat intelligence and machine learning algorithms to predict which vulnerabilities are most likely to be exploited in attacks. Read more about what VPR is and how it's different from CVSS.

VPR Score: 4.4


A PHP application running on the remote web server is affected by multiple vulnerabilities.


The version of Drupal running on the remote web server is 7.x prior to 7.52 or 8.x prior to 8.2.3. It is, therefore, affected by the multiple vulnerabilities :

- An information disclosure vulnerability exists in the taxonomy module when using access query tags that are inconsistent with the standard system used by Drupal Core. An unauthenticated, remote attacker can exploit this to disclose sensitive information regarding taxonomy terms. (CVE-2016-9449)

- A flaw exists in the password reset form due to a failure to properly specify a cache context. An unauthenticated, remote attacker can exploit this to poison the cache, by adding, for example, unwanted content to the page. Note that this issue only affects version 8.x. (CVE-2016-9450)

- A cross-site redirection vulnerability exists in the confirmation form due to improper validation of input before returning it to users. An unauthenticated, remote attacker can exploit this, via a specially crafted link, to redirect the user to a website of the attacker's choosing. Note that this issue only affects version 7.x. (CVE-2016-9451)

- A denial of service vulnerability exists in the transliterate mechanism when handling specially crafted URLs. An unauthenticated, remote attacker can exploit this to cause a crash. Note that this issue only affects version 8.x. (CVE-2016-9452)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.


Upgrade to Drupal version 7.52 / 8.2.3 or later.

See Also




Plugin Details

Severity: Medium

ID: 95026

File Name: drupal_8_2_3.nasl

Version: 1.10

Type: remote

Family: CGI abuses

Published: 2016/11/21

Updated: 2019/11/14

Dependencies: 18638

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Medium

VPR Score: 4.4

CVSS Score Source: CVE-2016-9450

CVSS v2.0

Base Score: 5

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:drupal:drupal

Required KB Items: www/PHP, installed_sw/Drupal, Settings/ParanoidReport

Exploit Ease: No known exploits are available

Patch Publication Date: 2016/11/16

Vulnerability Publication Date: 2016/11/16

Reference Information

CVE: CVE-2016-9449, CVE-2016-9450, CVE-2016-9451, CVE-2016-9452

BID: 94367