HP Network Node Manager i < 10.20 Multiple Vulnerabilities

High Nessus Plugin ID 94933


A web management application running on the remote host is affected by multiple vulnerabilities.


The HP Network Node Manager i (NNMi) server running on the remote host is a version prior to 10.20. It is, therefore, affected by multiple vulnerabilities :

- A remote code execution vulnerability exists due to unsafe deserialize calls of unauthenticated Java objects to the Apache Commons Collections (ACC) library. An unauthenticated, remote attacker can exploit this to execute arbitrary code on the target host.

- Multiple reflected cross-site scripting (XSS) vulnerabilities exist due to improper validation of input before returning it to users. An unauthenticated, remote attacker can exploit these, via a specially crafted request, to execute arbitrary script code in a user's browser session. (CVE-2016-4399, CVE-2016-4400)


Upgrade NNMi to version 10.20 or later.

See Also



Plugin Details

Severity: High

ID: 94933

File Name: hp_nnmi_console_10_10.nasl

Version: 1.8

Type: remote

Family: CGI abuses

Published: 2016/11/17

Modified: 2018/06/14

Dependencies: 70146

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 9

Temporal Score: 6.7

Vector: CVSS2#AV:N/AC:L/Au:S/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 9

Temporal Score: 7.8

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:hp:network_node_manager_i

Required KB Items: installed_sw/HP Network Node Manager i, Settings/ParanoidReport

Patch Publication Date: 2016/11/04

Vulnerability Publication Date: 2015/01/28

Reference Information

CVE: CVE-2016-4398, CVE-2016-4399, CVE-2016-4400

BID: 94195

HP: emr_na-c05325823, HPSBGN03656, PSRT110235

CERT: 576313