Apple iTunes < 12.5.2 Multiple Vulnerabilities (credentialed check)

High Nessus Plugin ID 94915


The remote host contains an application that is affected by multiple vulnerabilities.


The version of Apple iTunes installed on the remote Windows host is prior to 12.5.2. It is, therefore, affected by multiple vulnerabilities :

- A cross-origin bypass vulnerability exists in WebKit due to improper handling of the location attribute. An unauthenticated, remote attacker can exploit this, by convincing a user to visit a maliciously crafted website, to bypass cross-origin policies and disclose sensitive user data. (CVE-2016-4613)

- Multiple memory corruption errors exist in WebKit due to improper validation of user-supplied input. An unauthenticated, remote attacker can exploit these issues, by convincing a user to visit a maliciously crafted website, to execute arbitrary code.

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.


Upgrade to Apple iTunes version 12.5.2 or later.

See Also

Plugin Details

Severity: High

ID: 94915

File Name: itunes_12_5_2.nasl

Version: $Revision: 1.3 $

Type: local

Agent: windows

Family: Windows

Published: 2016/11/16

Modified: 2016/11/23

Dependencies: 25996

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 6.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C


Base Score: 9.6

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H

Vulnerability Information

CPE: cpe:/a:apple:itunes

Required KB Items: installed_sw/iTunes Version, SMB/Registry/Enumerated

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2016/10/27

Vulnerability Publication Date: 2016/10/27

Reference Information

CVE: CVE-2016-4613, CVE-2016-7578

BID: 93949

OSVDB: 146224, 146369

APPLE-SA: APPLE-SA-2016-10-27-3