GLSA-201611-05 : tnftp: Arbitrary code execution

High Nessus Plugin ID 94889


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-201611-05 (tnftp: Arbitrary code execution)

The fetch_url function in usr.bin/ftp/fetch.c allows remote attackers to execute arbitrary commands via a Impact :

A remote attacker could possibly execute arbitrary code with the privileges of the process.
Workaround :

There is no known workaround at this time.


All tnftp users should upgrade to the latest version:
# emerge --sync # emerge --ask --verbose --oneshot '>=net-ftp/tnftp-20141104'

See Also

Plugin Details

Severity: High

ID: 94889

File Name: gentoo_GLSA-201611-05.nasl

Version: $Revision: 2.3 $

Type: local

Published: 2016/11/15

Modified: 2017/11/02

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:tnftp, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2016/11/15

Exploitable With

Metasploit (tnftp "savefile" Arbitrary Command Execution)

Reference Information

CVE: CVE-2014-8517

GLSA: 201611-05