Google Chrome < 54.0.2840.87 V8 Globals Stable Map Assumption Handling RCE

High Nessus Plugin ID 94580


A web browser installed on the remote Windows host is affected by a remote code execution vulnerability.


The version of Google Chrome installed on the remote Windows host is prior to 54.0.2840.87. It is, therefore, affected by a remote code execution vulnerability in the V8 component due to an out-of-bounds access error that occurs when handling stable map assumptions for globals. An unauthenticated, remote attacker can exploit this, via a specially crafted website, to cause a denial of service condition or the execution of arbitrary code.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.


Upgrade to Google Chrome version 54.0.2840.87 or later.

See Also

Plugin Details

Severity: High

ID: 94580

File Name: google_chrome_54_0_2840_87.nasl

Version: $Revision: 1.5 $

Type: local

Agent: windows

Family: Windows

Published: 2016/11/04

Modified: 2016/12/12

Dependencies: 34196

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 7.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:POC/RL:OF/RC:ND


Base Score: 8.8

Temporal Score: 7.9

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:X

Vulnerability Information

CPE: cpe:/a:google:chrome

Required KB Items: SMB/Google_Chrome/Installed

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2016/10/27

Vulnerability Publication Date: 2016/10/27

Reference Information

CVE: CVE-2016-5198

BID: 94079

OSVDB: 146629