RHEL 7 : gimp (RHSA-2016:2589)

Medium Nessus Plugin ID 94552


The remote Red Hat host is missing one or more security updates.


An update for gimp and gimp-help is now available for Red Hat Enterprise Linux 7.

Red Hat Product Security has rated this update as having a security impact of Moderate. A Common Vulnerability Scoring System (CVSS) base score, which gives a detailed severity rating, is available for each vulnerability from the CVE link(s) in the References section.

The GIMP (GNU Image Manipulation Program) is an image composition and editing program. GIMP provides a large image manipulation toolbox, including channel operations and layers, effects, sub-pixel imaging and anti-aliasing, and conversions, all with multi-level undo.

The following packages have been upgraded to a newer upstream version:
gimp (2.8.16), gimp-help (2.8.2). (BZ#1298226, BZ#1370595)

Security Fix(es) :

* Multiple use-after-free vulnerabilities were found in GIMP in the channel and layer properties parsing process when loading XCF files.
An attacker could create a specially crafted XCF file which could cause GIMP to crash. (CVE-2016-4994)

Additional Changes :

For detailed information on changes in this release, see the Red Hat Enterprise Linux 7.3 Release Notes linked from the References section.


Update the affected packages.

See Also




Plugin Details

Severity: Medium

ID: 94552

File Name: redhat-RHSA-2016-2589.nasl

Version: $Revision: 2.3 $

Type: local

Agent: unix

Published: 2016/11/04

Modified: 2017/01/10

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Temporal Score: 5

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C


Base Score: 7.8

Temporal Score: 6.8

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:redhat:enterprise_linux:gimp, p-cpe:/a:redhat:enterprise_linux:gimp-debuginfo, p-cpe:/a:redhat:enterprise_linux:gimp-devel, p-cpe:/a:redhat:enterprise_linux:gimp-devel-tools, p-cpe:/a:redhat:enterprise_linux:gimp-help, p-cpe:/a:redhat:enterprise_linux:gimp-help-ca, p-cpe:/a:redhat:enterprise_linux:gimp-help-da, p-cpe:/a:redhat:enterprise_linux:gimp-help-de, p-cpe:/a:redhat:enterprise_linux:gimp-help-el, p-cpe:/a:redhat:enterprise_linux:gimp-help-en_GB, p-cpe:/a:redhat:enterprise_linux:gimp-help-es, p-cpe:/a:redhat:enterprise_linux:gimp-help-fr, p-cpe:/a:redhat:enterprise_linux:gimp-help-it, p-cpe:/a:redhat:enterprise_linux:gimp-help-ja, p-cpe:/a:redhat:enterprise_linux:gimp-help-ko, p-cpe:/a:redhat:enterprise_linux:gimp-help-nl, p-cpe:/a:redhat:enterprise_linux:gimp-help-nn, p-cpe:/a:redhat:enterprise_linux:gimp-help-pt_BR, p-cpe:/a:redhat:enterprise_linux:gimp-help-ru, p-cpe:/a:redhat:enterprise_linux:gimp-help-sl, p-cpe:/a:redhat:enterprise_linux:gimp-help-sv, p-cpe:/a:redhat:enterprise_linux:gimp-help-zh_CN, p-cpe:/a:redhat:enterprise_linux:gimp-libs, cpe:/o:redhat:enterprise_linux:7

Required KB Items: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list, Host/cpu

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2016/11/03

Reference Information

CVE: CVE-2016-4994

OSVDB: 140355

RHSA: 2016:2589