Apache Struts 2.3.1 < 2.3.31 / 2.5.x < 2.5.5 Convention Plugin Path Traversal RCE (S2-042)

High Nessus Plugin ID 94336

Synopsis

A web application running on the remote host uses a Java framework that is affected by a remote code execution vulnerability

Description

The version of Apache Struts running on the remote host is 2.3.1 prior to 2.3.31 or 2.5.x prior to 2.5.5. It is, therefore, affected by a remote code execution vulnerability in the Convention plugin due to a flaw that allows traversing outside of a restricted path. An unauthenticated, remote attacker can exploit this, via a specially crafted URL which could be used for path traversal and execution of arbitrary code on the remote server.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Apache Struts version 2.3.31 / 2.5.5 or later.

See Also

http://www.nessus.org/u?73075a47

http://www.nessus.org/u?4b6be1e7

Plugin Details

Severity: High

ID: 94336

File Name: struts_2_3_31_win_local.nasl

Version: 1.13

Type: combined

Agent: windows, macosx, unix

Family: Misc.

Published: 2016/10/27

Updated: 2019/09/06

Dependencies: 11936, 73943, 122235, 99671

Configuration: Enable paranoid mode

Risk Information

Risk Factor: High

CVSS Score Source: CVE-2016-6795

CVSS v2.0

Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 9.8

Temporal Score: 8.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:struts

Required KB Items: Settings/ParanoidReport

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2016/10/05

Vulnerability Publication Date: 2016/10/05

Reference Information

CVE: CVE-2016-6795

BID: 93773