MS16-126: Security Update for Microsoft Internet Messaging API (3196067)

Medium Nessus Plugin ID 94009


The remote host is affected by an information disclosure vulnerability.


The remote Windows host is missing a security update. It is, therefore, affected by an information disclosure vulnerability in the Internet Messaging API due to improper handling of objects in memory.
An unauthenticated, remote attacker can exploit this, by convincing a user to visit a specially crafted website, to enumerate the files on the disk drive.


Microsoft has released a set of patches for Windows Vista, 2008, 7, and 2008 R2. Note that MS16-118 must also be installed to fully resolve CVE-2016-3298.

See Also

Plugin Details

Severity: Medium

ID: 94009

File Name: smb_nt_ms16-126.nasl

Version: $Revision: 1.6 $

Type: local

Agent: windows

Published: 2016/10/12

Modified: 2017/07/12

Dependencies: 93962, 13855, 57033

Risk Information

Risk Factor: Medium


Base Score: 4.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:N/A:N


Base Score: 4.3

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:N

Vulnerability Information

CPE: cpe:/o:microsoft:windows

Required KB Items: SMB/MS_Bulletin_Checks/Possible

Patch Publication Date: 2016/10/11

Vulnerability Publication Date: 2016/10/11

Reference Information

CVE: CVE-2016-3298

BID: 93392

OSVDB: 145493

MSFT: MS16-126

MSKB: 3196067, 3193515, 3192391, 3185330

IAVB: 2016-B-0150