GLSA-201610-05 : Subversion, Serf: Multiple Vulnerabilities

High Nessus Plugin ID 93992


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-201610-05 (Subversion, Serf: Multiple Vulnerabilities)

Multiple vulnerabilities have been discovered in Subversion and Serf.
Please review the CVE identifiers referenced below for details Impact :

A remote attacker could possibly execute arbitrary code with the privileges of the process, conduct a man-in-the-middle attack, obtain sensitive information, or cause a Denial of Service Condition.
Workaround :

There is no known workaround at this time.


All Subversion users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=dev-vcs/subversion-1.9.4' All Serf users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=net-libs/serf-1.3.7'

See Also

Plugin Details

Severity: High

ID: 93992

File Name: gentoo_GLSA-201610-05.nasl

Version: $Revision: 2.1 $

Type: local

Published: 2016/10/12

Modified: 2016/10/12

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 9

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:C


Base Score: 8.6

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:H

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:serf, p-cpe:/a:gentoo:linux:subversion, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2016/10/11

Reference Information

CVE: CVE-2014-0032, CVE-2014-3504, CVE-2014-3522, CVE-2014-3528, CVE-2015-0202, CVE-2015-0248, CVE-2015-0251, CVE-2015-3184, CVE-2015-3187, CVE-2015-5259, CVE-2016-2167, CVE-2016-2168

GLSA: 201610-05