Debian DSA-3687-1 : nspr - security update

High Nessus Plugin ID 93870

Synopsis

The remote Debian host is missing a security-related update.

Description

Two vulnerabilities were reported in NSPR, a library to abstract over operating system interfaces developed by the Mozilla project.

- CVE-2016-1951 q1 reported that the NSPR implementation of sprintf-style string formatting function miscomputed memory allocation sizes, potentially leading to heap-based buffer overflows

The second issue concerns environment variable processing in NSPR. The library did not ignore environment variables used to configuring logging and tracing in processes which underwent a SUID/SGID/AT_SECURE transition at process start. In certain system configurations, this allowed local users to escalate their privileges.

In addition, this nspr update contains further stability and correctness fixes and contains support code for an upcoming nss update.

Solution

Upgrade the nspr packages.

For the stable distribution (jessie), these problems have been fixed in version 2:4.12-1+debu8u1.

See Also

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=583651

https://security-tracker.debian.org/tracker/CVE-2016-1951

https://packages.debian.org/source/jessie/nspr

https://www.debian.org/security/2016/dsa-3687

Plugin Details

Severity: High

ID: 93870

File Name: debian_DSA-3687.nasl

Version: 2.8

Type: local

Agent: unix

Published: 2016/10/06

Updated: 2018/11/10

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 8.6

Temporal Score: 7.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:nspr, cpe:/o:debian:debian_linux:8.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2016/10/05

Reference Information

CVE: CVE-2016-1951

DSA: 3687