Asterisk chan_sip Overlap Dialing Feature DoS (AST-2016-007)

Medium Nessus Plugin ID 93534


A telephony application running on the remote host is affected by a denial of service vulnerability.


According to its SIP banner, the version of Asterisk running on the remote host is 11.x prior to 11.23.1, 13.x prior to 13.11.1, 11.6-certx prior to 11.6-cert15, or 13.8-certx prior to 13.8-cert3. It is, therefore, affected by a flaw in the overlap dialing feature in chan_sip due to a failure to release old RTP resources before allocating new ones. An unauthenticated, remote attacker can exploit this to exhaust available RTP ports and stop new RTP sessions from being created, resulting in a denial of service condition. This vulnerability only affects installations using the overlap dialing support feature.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.


Upgrade to Asterisk version 11.23.1 / 13.11.1 / 11.6-cert15 / 13.8-cert3 or later. Alternatively, disable the overlap dialing support feature.

See Also

Plugin Details

Severity: Medium

ID: 93534

File Name: asterisk_ast_2016_007.nasl

Version: $Revision: 1.6 $

Type: remote

Family: Misc.

Published: 2016/09/15

Modified: 2017/02/16

Dependencies: 63202

Risk Information

Risk Factor: Medium


Base Score: 5

Temporal Score: 4.1

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:ND


Base Score: 7.5

Temporal Score: 6.9

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:X

Vulnerability Information

CPE: cpe:/a:digium:asterisk

Required KB Items: asterisk/sip_detected, Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2016/09/08

Vulnerability Publication Date: 2016/09/08

Reference Information

BID: 92888

OSVDB: 144030