VMware Tools 9.x / 10.x < 10.0.9 Multiple Privilege Escalations (VMSA-2016-0014) (Mac OS X)

High Nessus Plugin ID 93520


A virtualization application installed on the remote Mac OS X host is affected by multiple privilege escalation vulnerabilities.


The version of VMware Tools installed on the remote Mac OS X host is 9.x or 10.x prior to 10.0.9. It is, therefore, affected by multiple NULL pointer dereference flaws in the graphic acceleration functions due to improper memory handling. A local attacker can exploit these to gain elevated privileges.


Upgrade to VMware Tools version 10.0.9 or later.

See Also


Plugin Details

Severity: High

ID: 93520

File Name: macosx_vmware_tools_vmsa_2016_0014.nasl

Version: $Revision: 1.5 $

Type: local

Agent: macosx

Published: 2016/09/15

Modified: 2016/11/28

Dependencies: 93522

Risk Information

Risk Factor: High


Base Score: 7.2

Temporal Score: 5.3

Vector: CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C


Base Score: 8.4

Temporal Score: 7.3

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:vmware:tools

Required KB Items: Host/local_checks_enabled, installed_sw/VMware Tools

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2016/09/13

Vulnerability Publication Date: 2016/09/13

Reference Information

CVE: CVE-2016-7079, CVE-2016-7080

BID: 92938

OSVDB: 144220, 144221

VMSA: 2016-0014