Blue Coat ProxyClient < / 3.4.x < Certificate Validation MitM

High Nessus Plugin ID 93404


An application installed on the remote host is affected by a man-in-the-middle vulnerability.


The version of Blue Coat ProxyClient installed on the remote Windows host is either prior to or is 3.4.x prior to It is, therefore, affected by a man-in-the-middle (MitM) vulnerability due to improper validation of the Client Manager certificate. A MitM attacker can exploit this, via a specially crafted certificate, to spoof ProxySG Client Managers, allowing the attacker to modify configurations and execute arbitrary software updates.


Upgrade to Blue Coat ProxyClient version / or later.

See Also

Plugin Details

Severity: High

ID: 93404

File Name: macosx_bluecoat_proxyclient_3_4_4_10.nasl

Version: $Revision: 1.4 $

Type: local

Agent: macosx

Published: 2016/09/09

Modified: 2016/11/28

Dependencies: 93407

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 8.1

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C


Base Score: 8.1

Temporal Score: 7.7

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:bluecoat:proxyclient

Required KB Items: installed_sw/ProxyClientUI

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2015/01/23

Vulnerability Publication Date: 2015/01/23

Reference Information

CVE: CVE-2015-1454

BID: 73150

IAVA: 2016-A-0227