IBM BigFix Server 9.2.x < BES Gather XSS

Medium Nessus Plugin ID 93224


An infrastructure management application running on the remote host is affected by a cross-site scripting vulnerability.


According to its self-reported version, the IBM BigFix Server running on the remote host is version 9.2.x prior to It is, therefore, affected by a reflected cross-site scripting (XSS) vulnerability that exists in the BES gather function due to improper validation of input before returning it to users. An unauthenticated, remote attacker can exploit this, via a specially crafted URL, to execute arbitrary script code in a user's browser session.

IBM BigFix was formerly known as Tivoli Endpoint Manager, IBM Endpoint Manager, and IBM BigFix Endpoint Manager.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.


Upgrade to IBM BigFix Server version or later.

See Also

Plugin Details

Severity: Medium

ID: 93224

File Name: ibm_tem_9_2_7_53.nasl

Version: $Revision: 1.3 $

Type: remote

Family: Web Servers

Published: 2016/08/30

Modified: 2016/11/23

Dependencies: 66269

Risk Information

Risk Factor: Medium


Base Score: 4.3

Temporal Score: 3.6

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:ND


Base Score: 4.7

Temporal Score: 4.3

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:L/A:N

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:X

Vulnerability Information

CPE: cpe:/a:ibm:tivoli_endpoint_manager, cpe:/a:ibm:bigfix_platform

Required KB Items: www/BigFixHTTPServer

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2016/07/08

Vulnerability Publication Date: 2016/07/08

Reference Information

CVE: CVE-2016-0269

BID: 91690

OSVDB: 141447