WordPress 4.5.x < 4.6 Multiple Vulnerabilities

Medium Nessus Plugin ID 93111

Synopsis

A PHP application running on the remote web server is affected by multiple vulnerabilities.

Description

According to its self-reported version number, the WordPress application running on the remote web server is 4.5.x prior to 4.6. It is, therefore, affected by multiple vulnerabilities :

- A path traversal vulnerability exists in the WordPress Admin API in the wp_ajax_update_plugin() function in ajax-actions.php due to improper sanitization of user-supplied input. An authenticated, remote attacker can exploit this, via a specially crafted request, to cause a denial of service condition. (CVE-2016-6896)

- A cross-site request forgery vulnerability (XSRF) exists in the admin-ajax.php script due to a failure to require multiple steps, explicit confirmation, or a unique token when performing certain sensitive actions. An unauthenticated, remote attacker can exploit this, by convincing a user to follow a specially crafted link, to perform arbitrary AJAX updates. (CVE-2016-6897)

- An information disclosure vulnerability exists in the wp_ajax_update_plugin() function in the ajax-actions.php script due to performing a call to get_plug_data() before checking capabilities. An authenticated, remote attacker can exploit this to bypass intended read-access restrictions, resulting in a disclosure of sensitive information. (CVE-2016-10148)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to WordPress version 4.6 or later.

See Also

https://wordpress.org/news/2016/08/pepper/

http://seclists.org/fulldisclosure/2016/Aug/98

Plugin Details

Severity: Medium

ID: 93111

File Name: wordpress_4_6.nasl

Version: $Revision: 1.7 $

Type: remote

Family: CGI abuses

Published: 2016/08/25

Modified: 2017/02/01

Dependencies: 18297

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 6.8

Temporal Score: 5.6

Vector: CVSS2#AV:N/AC:L/Au:S/C:N/I:N/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:ND

CVSSv3

Base Score: 6.5

Temporal Score: 6

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:X

Vulnerability Information

CPE: cpe:/a:wordpress:wordpress

Required KB Items: www/PHP, installed_sw/WordPress, Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2016/08/16

Vulnerability Publication Date: 2016/08/20

Reference Information

CVE: CVE-2016-6896, CVE-2016-6897, CVE-2016-10148

BID: 92572, 92573

OSVDB: 143416, 143345, 150699

EDB-ID: 40288