Palo Alto Networks PAN-OS 7.0.x < 7.0.8 Multiple Vulnerabilities (PAN-SA-2016-0008 / PAN-SA-2016-0009)

Medium Nessus Plugin ID 92942

Synopsis

The remote host is affected by multiple vulnerabilities.

Description

The version of Palo Alto Networks PAN-OS running on the remote host is 7.0.x prior to 7.0.8. It is, therefore, affected by the following vulnerabilities :

- A denial of service vulnerability exists in the API hosted on the management interface, specifically in the panUserLogin() function within panmodule.so, due to improper validation of user-supplied input to the 'username' and 'password' parameters. An unauthenticated, remote attacker can exploit this, via a crafted request, to cause the process to terminate.
(PAN-SA-2016-0008)

- A cross-site scripting (XSS) vulnerability exists in the Application Command Center (ACC) due to improper sanitization of user-supplied input before returning it to users. An authenticated, remote attacker can exploit this, via a specially crafted request, to execute arbitrary script code in a user's browser session.
(PAN-SA-2016-0009, CVE-2016-2219)

Solution

Upgrade to Palo Alto Networks PAN-OS version 7.0.8 or later.

See Also

https://securityadvisories.paloaltonetworks.com/Home/Detail/41

https://securityadvisories.paloaltonetworks.com/Home/Detail/42

http://www.tenable.com/security/research/tra-2016-19

Plugin Details

Severity: Medium

ID: 92942

File Name: palo_alto_PAN-SA-2016-0009.nasl

Version: $Revision: 1.5 $

Type: combined

Published: 2016/08/12

Modified: 2016/12/05

Dependencies: 72816

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 5

Temporal Score: 4.1

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:ND

CVSSv3

Base Score: 5.3

Temporal Score: 4.9

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:X

Vulnerability Information

CPE: cpe:/o:paloaltonetworks:pan-os

Required KB Items: Host/Palo_Alto/Firewall/Version, Host/Palo_Alto/Firewall/Full_Version

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2016/06/27

Vulnerability Publication Date: 2016/06/27

Reference Information

CVE: CVE-2016-2219

BID: 91461, 91468

TRA: TRA-2016-19