Debian DLA-567-2 : mysql-5.5 security and regression update

high Nessus Plugin ID 92762
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote Debian host is missing a security update.

Description

Several vulnerabilities have been found in the MySQL Database Server.
These vulnerabilities are addressed by upgrading MySQL to the recent upstream 5.5.50 version. Please refer to the MySQL 5.5 Release Notes and Oracle's Critical Patch Update advisory for further details :

https://dev.mysql.com/doc/relnotes/mysql/5.5/en/news-5-5-50.html http://www.oracle.com/technetwork/security-advisory/cpujul2016-2881720 .html

For Debian 7 'Wheezy', these problems have been fixed in version 5.5.50-0+deb7u2.

Regression note: I have wrongly built the previous 5.5.50-0+deb7u1 upload over the jessie-security debian packaging. Although I have not identified any issues on amd64, I have uploaded a new release built on the regular wheezy packaging.

We recommend that you upgrade your mysql-5.5 packages.

NOTE: Tenable Network Security has extracted the preceding description block directly from the DLA security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

Upgrade the affected packages.

See Also

https://dev.mysql.com/doc/relnotes/mysql/5.5/en/news-5-5-50.html

https://lists.debian.org/debian-lts-announce/2016/08/msg00008.html

https://packages.debian.org/source/wheezy/mysql-5.5

http://www.nessus.org/u?1f22d813

Plugin Details

Severity: High

ID: 92762

File Name: debian_DLA-567.nasl

Version: 2.8

Type: local

Agent: unix

Published: 8/8/2016

Updated: 1/11/2021

Dependencies: ssh_get_info.nasl

Risk Information

VPR

Risk Factor: Medium

Score: 6.5

CVSS v2

Risk Factor: Medium

Base Score: 6.8

Temporal Score: 5

Vector: AV:N/AC:L/Au:S/C:N/I:N/A:C

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: High

Base Score: 8.1

Temporal Score: 7.1

Vector: CVSS:3.0/AV:L/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:libmysqlclient-dev, p-cpe:/a:debian:debian_linux:libmysqlclient18, p-cpe:/a:debian:debian_linux:libmysqld-dev, p-cpe:/a:debian:debian_linux:libmysqld-pic, p-cpe:/a:debian:debian_linux:mysql-client, p-cpe:/a:debian:debian_linux:mysql-client-5.5, p-cpe:/a:debian:debian_linux:mysql-common, p-cpe:/a:debian:debian_linux:mysql-server, p-cpe:/a:debian:debian_linux:mysql-server-5.5, p-cpe:/a:debian:debian_linux:mysql-server-core-5.5, p-cpe:/a:debian:debian_linux:mysql-source-5.5, p-cpe:/a:debian:debian_linux:mysql-testsuite-5.5, cpe:/o:debian:debian_linux:7.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Ease: No known exploits are available

Patch Publication Date: 8/5/2016

Reference Information

CVE: CVE-2016-3477, CVE-2016-3521, CVE-2016-3615, CVE-2016-5440