GLSA-201607-17 : BeanShell: Arbitrary code execution

Medium Nessus Plugin ID 92653


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-201607-17 (BeanShell: Arbitrary code execution)

An application that includes BeanShell on the classpath may be vulnerable if another part of the application uses Java serialization or XStream to deserialize data from an untrusted source.
Impact :

Remote attackers could execute arbitrary code including shell commands.
Workaround :

There is no known workaround at this time.


All BeanShell users should upgrade to the latest version:
# emerge --sync # emerge --ask --verbose --oneshot '>=dev-java/bsh-2.0_beta6'

See Also

Plugin Details

Severity: Medium

ID: 92653

File Name: gentoo_GLSA-201607-17.nasl

Version: $Revision: 2.2 $

Type: local

Published: 2016/08/01

Modified: 2017/10/02

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P


Base Score: 8.1

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:bsh, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2016/07/30

Reference Information

CVE: CVE-2016-2510

GLSA: 201607-17