Debian DLA-569-1 : xmlrpc-epi security update

High Nessus Plugin ID 92633

Synopsis

The remote Debian host is missing a security update.

Description

Integer signedness error in the simplestring_addn function in simplestring.c in xmlrpc-epi through 0.54.2 allows remote attackers to cause a denial of service (heap-based buffer overflow) or possibly have unspecified other impact via a long first argument to the PHP xmlrpc_encode_request function.

For Debian 7 'Wheezy', these problems have been fixed in version 0.54.2-1+deb7u1.

We recommend that you upgrade your xmlrpc-epi packages.

NOTE: Tenable Network Security has extracted the preceding description block directly from the DLA security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

Upgrade the affected packages.

See Also

https://lists.debian.org/debian-lts-announce/2016/07/msg00030.html

https://packages.debian.org/source/wheezy/xmlrpc-epi

Plugin Details

Severity: High

ID: 92633

File Name: debian_DLA-569.nasl

Version: 2.8

Type: local

Agent: unix

Published: 2016/08/01

Updated: 2018/07/09

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 9.8

Temporal Score: 8.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:libxmlrpc-epi-dev, p-cpe:/a:debian:debian_linux:libxmlrpc-epi0, p-cpe:/a:debian:debian_linux:libxmlrpc-epi0-dbg, cpe:/o:debian:debian_linux:7.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2016/07/29

Reference Information

CVE: CVE-2016-6296