Tenable SecurityCenter < 5.4.0 Multiple Vulnerabilities (TNS-2016-12)

high Nessus Plugin ID 92558
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

An application installed on the remote host is affected by multiple vulnerabilities.

Description

According to its self-reported version, the Tenable SecurityCenter application installed on the remote host is prior to 5.4.0. It is, therefore, affected by multiple vulnerabilities :

- An arbitrary code execution vulnerability exists in the bundled version of libcurl due to using an insecure path to look for specific libraries, including the current working directory, which may not be under user control.
A remote attacker can exploit this to inject and execute arbitrary code in the context of the current user.
(CVE-2016-4802)

- Multiple flaws exist in the bundled version of libssh due to a failure to securely generate Diffie-Hellman secret keys. A man-in-the-middle attacker can exploit these flaws to intercept and decrypt SSH sessions.
(CVE-2016-0739, CVE-2016-0787)

- An integer overflow condition exists in the bundled version of libcurl due to improper validation of user-supplied input when handling 'timeval'. An attacker can exploit this to have an unspecified impact.

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Tenable SecurityCenter version 5.4.0 or later.

See Also

https://www.tenable.com/security/tns-2016-12

https://curl.haxx.se/docs/CVE-2016-4802.html

https://curl.haxx.se/changes.html#7_48_0

https://www.libssh2.org/adv_20160223.html

Plugin Details

Severity: High

ID: 92558

File Name: securitycenter_5_4.nasl

Version: 1.16

Type: combined

Agent: unix

Family: Misc.

Published: 7/26/2016

Updated: 10/9/2020

Dependencies: securitycenter_installed.nbin, securitycenter_detect.nbin

Risk Information

CVSS Score Source: CVE-2016-4802

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: Medium

Base Score: 6.9

Temporal Score: 5.1

Vector: AV:L/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: High

Base Score: 7.8

Temporal Score: 6.8

Vector: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:tenable:securitycenter

Exploit Ease: No known exploits are available

Patch Publication Date: 7/21/2016

Vulnerability Publication Date: 2/11/2016

Reference Information

CVE: CVE-2016-0739, CVE-2016-0787, CVE-2016-4802

BID: 83186, 83389, 90997