RHEL 5 / 6 / 7 : java-1.7.0-oracle (RHSA-2016:1476)

Medium Nessus Plugin ID 92509

Synopsis

The remote Red Hat host is missing one or more security updates.

Description

An update for java-1.7.0-oracle is now available for Oracle Java for Red Hat Enterprise Linux 5, Oracle Java for Red Hat Enterprise Linux 6, and Oracle Java for Red Hat Enterprise Linux 7.

Red Hat Product Security has rated this update as having a security impact of Critical. A Common Vulnerability Scoring System (CVSS) base score, which gives a detailed severity rating, is available for each vulnerability from the CVE link(s) in the References section.

[Updated 12 September 2016] This advisory has been updated to push packages into the Oracle Java for Red Hat Enterprise Linux 6 Compute Node channels. The packages included in this revised update have not been changed in any way from the packages included in the original advisory.

Oracle Java SE version 7 includes the Oracle Java Runtime Environment and the Oracle Java Software Development Kit.

This update upgrades Oracle Java SE 7 to version 7 Update 111.

Security Fix(es) :

* This update fixes multiple vulnerabilities in the Oracle Java Runtime Environment and the Oracle Java Software Development Kit.
Further information about these flaws can be found on the Oracle Java SE Critical Patch Update Advisory page, listed in the References section. (CVE-2016-3458, CVE-2016-3498, CVE-2016-3500, CVE-2016-3503, CVE-2016-3508, CVE-2016-3511, CVE-2016-3550, CVE-2016-3606)

Solution

Update the affected packages.

See Also

http://www.nessus.org/u?453b5f8c

http://www.oracle.com/technetwork/java/javaseproducts/documentation/

https://access.redhat.com/errata/RHSA-2016:1476

https://access.redhat.com/security/cve/cve-2016-3458

https://access.redhat.com/security/cve/cve-2016-3498

https://access.redhat.com/security/cve/cve-2016-3500

https://access.redhat.com/security/cve/cve-2016-3503

https://access.redhat.com/security/cve/cve-2016-3508

https://access.redhat.com/security/cve/cve-2016-3511

https://access.redhat.com/security/cve/cve-2016-3550

https://access.redhat.com/security/cve/cve-2016-3606

Plugin Details

Severity: Medium

ID: 92509

File Name: redhat-RHSA-2016-1476.nasl

Version: 2.9

Type: local

Agent: unix

Published: 2016/07/22

Updated: 2018/11/10

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.9

Temporal Score: 5.1

Vector: CVSS2#AV:L/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 9.6

Temporal Score: 8.3

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:redhat:enterprise_linux:java-1.7.0-oracle, p-cpe:/a:redhat:enterprise_linux:java-1.7.0-oracle-devel, p-cpe:/a:redhat:enterprise_linux:java-1.7.0-oracle-javafx, p-cpe:/a:redhat:enterprise_linux:java-1.7.0-oracle-jdbc, p-cpe:/a:redhat:enterprise_linux:java-1.7.0-oracle-plugin, p-cpe:/a:redhat:enterprise_linux:java-1.7.0-oracle-src, cpe:/o:redhat:enterprise_linux:5, cpe:/o:redhat:enterprise_linux:6, cpe:/o:redhat:enterprise_linux:7, cpe:/o:redhat:enterprise_linux:7.2

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2016/07/21

Reference Information

CVE: CVE-2016-3458, CVE-2016-3498, CVE-2016-3500, CVE-2016-3503, CVE-2016-3508, CVE-2016-3511, CVE-2016-3550, CVE-2016-3606

RHSA: 2016:1476