Drupal 8.x < 8.1.7 PHP HTTP_PROXY Environment Variable Namespace Collision Vulnerability (httpoxy)

Medium Nessus Plugin ID 92495

Synopsis

A PHP application running on the remote web server is affected by a man-in-the-middle vulnerability.

Description

The version of Drupal running on the remote web server is 8.x prior to 8.1.7. It is, therefore, affected by a man-in-the-middle vulnerability known as 'httpoxy' due to a failure to properly resolve namespace conflicts in accordance with RFC 3875 section 4.1.18. The HTTP_PROXY environment variable is set based on untrusted user data in the 'Proxy' header of HTTP requests. The HTTP_PROXY environment variable is used by some web client libraries to specify a remote proxy server. An unauthenticated, remote attacker can exploit this, via a crafted 'Proxy' header in an HTTP request, to redirect an application's internal HTTP traffic to an arbitrary proxy server where it may be observed or manipulated.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Drupal version 8.1.7 or later.

See Also

https://www.drupal.org/forum/newsletters/security-advisories-for-drupal-core/2016-07-18/drupal-core-highly-critical

https://httpoxy.org

https://www.drupal.org/project/drupal/releases/8.1.7

Plugin Details

Severity: Medium

ID: 92495

File Name: drupal_8_1_7.nasl

Version: 1.12

Type: remote

Family: CGI abuses

Published: 2016/07/21

Updated: 2019/11/19

Dependencies: 18638

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2016-5385

CVSS v2.0

Base Score: 5.1

Temporal Score: 4.2

Vector: CVSS2#AV:N/AC:H/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:ND

CVSS v3.0

Base Score: 8.1

Temporal Score: 7.1

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:drupal:drupal

Required KB Items: www/PHP, installed_sw/Drupal, Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2016/07/18

Vulnerability Publication Date: 2016/07/18

Reference Information

CVE: CVE-2016-5385

BID: 91821

CERT: 797896