GLSA-201607-13 : libbsd: Arbitrary code execution

High Nessus Plugin ID 92483


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-201607-13 (libbsd: Arbitrary code execution)

libbsd contains a buffer overflow in the fgetwln() function. An if statement, which is responsible for checking the necessity to reallocate memory in the target buffer, is off by one therefore an out of bounds write occurs.
Impact :

Remote attackers could potentially execute arbitrary code with the privileges of the process.
Workaround :

There is no known workaround at this time.


All libbsd users should upgrade to the latest version:
# emerge --sync # emerge --ask --verbose --oneshot '>=dev-libs/libbsd-0.8.2'

See Also

Plugin Details

Severity: High

ID: 92483

File Name: gentoo_GLSA-201607-13.nasl

Version: $Revision: 2.3 $

Type: local

Published: 2016/07/21

Modified: 2017/01/23

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P


Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:libbsd, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2016/07/20

Reference Information

CVE: CVE-2016-2090

GLSA: 201607-13