GLSA-201607-10 : Varnish: Multiple vulnerabilities

Medium Nessus Plugin ID 92480


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-201607-10 (Varnish: Multiple vulnerabilities)

Varnish fails to properly validate input from HTTP headers, and does not deny requests with multiple Content-Length headers.
Impact :

Remote attackers could conduct an HTTP response splitting attack, which may further enable them to conduct Cross-Site Scripting (XSS), Cache Poisoning, Defacement, and Page Hijacking.
Workaround :

There is no known workaround at this time.


All Varnish users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=www-servers/varnish-3.0.7'

See Also

Plugin Details

Severity: Medium

ID: 92480

File Name: gentoo_GLSA-201607-10.nasl

Version: $Revision: 2.2 $

Type: local

Published: 2016/07/21

Modified: 2016/10/10

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:P/A:N


Base Score: 7.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:varnish, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2016/07/20

Reference Information

CVE: CVE-2015-8852

GLSA: 201607-10