Samba 4.x < 4.2.14 / 4.3.x < 4.3.11 / 4.4.x < 4.4.5 SMB2/3 Client Connection Required Signing Downgrade

Medium Nessus Plugin ID 92466


The remote Samba server is affected by a signature downgrade vulnerability.


The version of Samba running on the remote host is 4.x prior to 4.2.14, 4.3.x prior to 4.3.11, or 4.4.x prior to 4.4.5. It is, therefore, affected by a flaw in libcli/smb/smbXcli_base.c that is triggered when handling SMB2 and SMB3 client connections. A man-in-the-middle attacker can exploit this, by injecting the SMB2_SESSION_FLAG_IS_GUEST or SMB2_SESSION_FLAG_IS_NULL flags, to downgrade the required signing for a client connection, allowing the attacker to spoof SMB2 and SMB3 servers.


Upgrade to Samba version 4.2.14 / 4.3.11 / 4.4.5 or later.

See Also

Plugin Details

Severity: Medium

ID: 92466

File Name: samba_4_4_5.nasl

Version: $Revision: 1.4 $

Type: remote

Family: Misc.

Published: 2016/07/20

Modified: 2016/12/27

Dependencies: 10785

Risk Information

Risk Factor: Medium


Base Score: 6.8

Temporal Score: 5

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:samba:samba

Required KB Items: SMB/NativeLanManager, SMB/samba, Settings/ParanoidReport

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2016/07/16

Vulnerability Publication Date: 2016/07/07

Reference Information

CVE: CVE-2016-2119

BID: 91700

OSVDB: 141072