Debian DSA-3619-1 : libgd2 - security update

Medium Nessus Plugin ID 92327

Synopsis

The remote Debian host is missing a security-related update.

Description

Several vulnerabilities were discovered in libgd2, a library for programmatic graphics creation and manipulation. A remote attacker can take advantage of these flaws to cause a denial-of-service against an application using the libgd2 library (application crash), or potentially to execute arbitrary code with the privileges of the user running the application.

Solution

Upgrade the libgd2 packages.

For the stable distribution (jessie), these problems have been fixed in version 2.1.0-5+deb8u4.

See Also

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=829014

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=829062

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=829694

https://packages.debian.org/source/jessie/libgd2

https://www.debian.org/security/2016/dsa-3619

Plugin Details

Severity: Medium

ID: 92327

File Name: debian_DSA-3619.nasl

Version: 2.9

Type: local

Agent: unix

Published: 2016/07/18

Updated: 2018/11/10

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.8

Temporal Score: 5

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 9.1

Temporal Score: 7.9

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:libgd2, cpe:/o:debian:debian_linux:8.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2016/07/15

Reference Information

CVE: CVE-2016-5116, CVE-2016-5766, CVE-2016-6128, CVE-2016-6132, CVE-2016-6161, CVE-2016-6214, CVE-2016-6905

DSA: 3619