LibreOffice < 5.1.4 RTF Character Style Index RCE

High Nessus Plugin ID 91974


An application installed on the remote host is affected by a remote code execution vulnerability.


The version of LibreOffice installed on the remote Windows host is prior to 5.1.4. It is, therefore, affected by a use-after-free error during Rich Text Format (RTF) file parsing due to improper validation of the RTF character style index. An unauthenticated, remote attacker can exploit this, by convincing a user to open a specially crafted RTF file, to execute arbitrary code.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.


Upgrade to LibreOffice version 5.1.4 or later.

See Also

Plugin Details

Severity: High

ID: 91974

File Name: libreoffice_514.nasl

Version: $Revision: 1.5 $

Type: local

Agent: windows

Family: Windows

Published: 2016/07/08

Modified: 2017/03/06

Dependencies: 55573

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 6.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:libreoffice:libreoffice

Required KB Items: installed_sw/LibreOffice, SMB/Registry/Enumerated

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2016/06/28

Vulnerability Publication Date: 2016/06/27

Reference Information

CVE: CVE-2016-4324

BID: 91499

OSVDB: 140635