Palo Alto Networks PAN-OS Management Interface API Remote DoS (PAN-SA-2016-0008)

medium Nessus Plugin ID 91958
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote host is affected by a denial of service vulnerability.

Description

The Palo Alto Networks PAN-OS running on the remote host is affected by a denial of service vulnerability in the API hosted on the management interface, specifically in the panUserLogin() function within panmodule.so, due to improper validation of user-supplied input to the 'username' and 'password' parameters. An unauthenticated, remote attacker can exploit this, via a crafted request, to cause the process to terminate.

Note that PAN-OS is reportedly affected by other vulnerabilities as well; however, Nessus has not tested for these.

Solution

Upgrade to Palo Alto Networks PAN-OS version 7.0.8 or later.

See Also

https://securityadvisories.paloaltonetworks.com/Home/Detail/41

Plugin Details

Severity: Medium

ID: 91958

File Name: palo_alto_PAN-SA-2016-0008_remote.nasl

Version: 1.4

Type: remote

Published: 7/6/2016

Updated: 8/8/2018

Dependencies: palo_alto_webui_detect.nbin

Risk Information

CVSS v2

Risk Factor: Medium

Base Score: 5

Temporal Score: 3.7

Vector: AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/o:paloaltonetworks:pan-os

Required KB Items: www/palo_alto_panos

Patch Publication Date: 6/27/2016

Vulnerability Publication Date: 6/27/2016

Reference Information