ImageMagick 7.x < 7.0.1-10 Multiple Vulnerabilities

high Nessus Plugin ID 91763
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote Windows host has an application installed that is affected by multiple vulnerabilities.

Description

The remote Windows host has a version of ImageMagick installed that is 7.x prior to 7.0.1-10. It is, therefore, affected by the following vulnerabilities :

- An overflow condition exists in the ReadRLEImage() function in rle.c due to improper validation of user-supplied input. An unauthenticated, remote attacker can exploit this, by convincing a user to open a specially crafted RLE image, to cause a heap-based buffer overflow, resulting in a denial of service condition or the execution of arbitrary code.
(CVE-2016-10050)

- An unspecified flaw exists in the ConcatenateImages() function in magick-cli.c that is triggered when handling return values. An unauthenticated, remote attacker can exploit this to have an unspecified impact.
(CVE-2016-10060)

- An unspecified flaw exists in the ReadGROUP4Image() function in tiff.c that is triggered when handling return values. An unauthenticated, remote attacker can exploit this to have an unspecified impact.
(CVE-2016-10061)
- An unspecified flaw exists in the ReadGROUP4Image() function in tiff.c that is triggered when handling fwrite errors. An unauthenticated, remote attacker can exploit this to have an unspecified impact.
(CVE-2016-10062)

- A flaw exists in pes.c due to improper handling of PES blocks. An unauthenticated, remote attacker can exploit this to cause a process linked against the library to crash, resulting in a denial of service condition.

Solution

Upgrade to ImageMagick version 7.0.1-10 or later.

Note that you may need to manually uninstall the vulnerable version from the system.

See Also

http://www.imagemagick.org/script/changelog.php

https://github.com/ImageMagick/ImageMagick/issues/213

Plugin Details

Severity: High

ID: 91763

File Name: imagemagick_7_0_1_10.nasl

Version: 1.9

Type: local

Agent: windows

Family: Windows

Published: 6/22/2016

Updated: 11/14/2019

Dependencies: imagemagick_installed.nasl

Risk Information

CVSS Score Source: CVE-2016-10050

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: Medium

Base Score: 6.8

Temporal Score: 5

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: High

Base Score: 7.8

Temporal Score: 6.8

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:imagemagick:imagemagick

Required KB Items: installed_sw/ImageMagick

Exploit Ease: No known exploits are available

Patch Publication Date: 6/10/2016

Vulnerability Publication Date: 6/4/2016

Reference Information

CVE: CVE-2016-10050, CVE-2016-10060, CVE-2016-10061, CVE-2016-10062

BID: 95185, 95207, 95208, 95209