Google Chrome < 51.0.2704.103 Multiple Vulnerabilities

High Nessus Plugin ID 91716


A web browser installed on the remote Windows host is affected by multiple vulnerabilities.


The version of Google Chrome installed on the remote Windows host is prior to 51.0.2704.103. It is, therefore, affected by multiple vulnerabilities :

- A flaw exists in the individualCharacterRanges() function in CachingWordShaper.cpp that is triggered when handling invalid glyph shaping results. A remote attacker can exploit this issue to corrupt memory, resulting in the execution of code. (VulnDB 140128)

- A use-after-free error exists in the OnChannelMessage() function in that allows a remote attacker to dereference already freed memory, resulting in the execution of arbitrary code. (VulnDB 140129)

- An unspecified flaw exists in that allows a remote attacker to have an unspecified impact. (VulnDB 140130)


Upgrade to Google Chrome version 51.0.2704.103 or later.

See Also

Plugin Details

Severity: High

ID: 91716

File Name: google_chrome_51_0_2704_103.nasl

Version: $Revision: 1.4 $

Type: local

Agent: windows

Family: Windows

Published: 2016/06/20

Modified: 2016/08/02

Dependencies: 34196

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 6.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:google:chrome

Required KB Items: SMB/Google_Chrome/Installed

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2016/06/16

Vulnerability Publication Date: 2016/06/16

Reference Information

CVE: CVE-2016-1704

OSVDB: 140128, 140129, 140130