Debian DLA-513-1 : nspr security update

high Nessus Plugin ID 91577

Synopsis

The remote Debian host is missing a security update.

Description

It was discovered that there was a buffer overflow in a sprintf utility within nspr, the NetScape Portable Runtime library.

For Debian 7 'Wheezy', this issue has been fixed in nspr version 2:4.9.2-1+deb7u4.

We recommend that you upgrade your nspr packages.

NOTE: Tenable Network Security has extracted the preceding description block directly from the DLA security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

Upgrade the affected packages.

See Also

https://lists.debian.org/debian-lts-announce/2016/06/msg00014.html

https://packages.debian.org/source/wheezy/nspr

Plugin Details

Severity: High

ID: 91577

File Name: debian_DLA-513.nasl

Version: 2.11

Type: local

Agent: unix

Published: 6/14/2016

Updated: 1/11/2021

Supported Sensors: Frictionless Assessment Agent, Nessus Agent

Risk Information

VPR

Risk Factor: Medium

Score: 4.7

CVSS v2

Risk Factor: High

Base Score: 7.5

Temporal Score: 5.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: High

Base Score: 8.6

Temporal Score: 7.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:libnspr4, p-cpe:/a:debian:debian_linux:libnspr4-0d, p-cpe:/a:debian:debian_linux:libnspr4-dbg, p-cpe:/a:debian:debian_linux:libnspr4-dev, cpe:/o:debian:debian_linux:7.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Ease: No known exploits are available

Patch Publication Date: 6/12/2016

Reference Information

CVE: CVE-2016-1951