GLSA-201605-03 : libfpx: Denial of Service

Medium Nessus Plugin ID 91376

Synopsis

The remote Gentoo host is missing one or more security-related patches.

Description

The remote host is affected by the vulnerability described in GLSA-201605-03 (libfpx: Denial of Service)

A double free vulnerability has been discovered in the Free_All_Memory function in jpeg/dectile.c.
Impact :

A remote attacker could entice a user to open a specially crafted FPX image using an application linked against libfpx, possibly resulting in a Denial of Service condition.
Workaround :

There is no known workaround at this time.

Solution

All libfpx users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=media-libs/libfpx-1.3.1_p6' Packages which depend on this library may need to be recompiled. Tools such as revdep-rebuild may assist in identifying these packages.

See Also

https://security.gentoo.org/glsa/201605-03

Plugin Details

Severity: Medium

ID: 91376

File Name: gentoo_GLSA-201605-03.nasl

Version: $Revision: 2.1 $

Type: local

Published: 2016/05/31

Modified: 2016/05/31

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:libfpx, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2016/05/30

Reference Information

CVE: CVE-2012-0025

GLSA: 201605-03