Apple iTunes < 12.4 DLL Injection Arbitrary Code Execution (credentialed check)

High Nessus Plugin ID 91347


The remote host contains an application that is affected by a DLL injection vulnerability.


The version of Apple iTunes installed on the remote Windows host is prior to 12.4. It is, therefore, affected by a DLL (Dynamic Link Library) injection vulnerability in the setup component that is triggered when running the installer from an untrusted directory. An attacker can exploit this vulnerability by placing a specially crafted DLL file in the untrusted directory, resulting in the execution of arbitrary code in the context of the current user.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.


Upgrade to Apple iTunes version 12.4 or later.

See Also

Plugin Details

Severity: High

ID: 91347

File Name: itunes_12_4.nasl

Version: $Revision: 1.2 $

Type: local

Agent: windows

Family: Windows

Published: 2016/05/27

Modified: 2016/05/31

Dependencies: 25996

Risk Information

Risk Factor: High


Base Score: 7.2

Temporal Score: 5.3

Vector: CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:apple:itunes

Required KB Items: installed_sw/iTunes Version, SMB/Registry/Enumerated

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2016/05/16

Vulnerability Publication Date: 2016/05/16

Reference Information

CVE: CVE-2016-1742

OSVDB: 138643

APPLE-SA: APPLE-SA-2016-05-16-6