VMware vCenter Server 5.0.x < 5.0u3e / 5.1.x < 5.1u3b / 5.5.x < 5.5u3 (Linux) / 5.5.x < 5.5u3b (Windows) / 6.0.x < 6.0.0b JMX Deserialization RCE (VMSA-2016-0005)
Critical Nessus Plugin ID 91322
SynopsisA virtualization management application installed on the remote host is affected by a remote code execution vulnerability.
DescriptionThe version of VMware vCenter Server installed on the remote host is 5.0.x prior to 5.0u3e, 5.1.x prior to 5.1u3b, 5.5.x prior to 5.5u3 (Linux), 5.5.x prior to 5.5u3b (Windows), or 6.0.x prior to 6.0.0b.
It is, therefore, affected by a flaw in Oracle JMX when deserializing authentication credentials. An unauthenticated, remote attacker can exploit this to execute arbitrary code.
SolutionUpgrade to VMware vCenter Server version 5.0u3e (5.0.0 build-3073236) / 5.1u3b on Linux or Windows (5.1.0 build-3070521) / 5.1u3d on Windows (5.1.0 build-3814779) / 5.5u3 on Linux (5.5.0 build-3000241) / 5.5u3b on Windows (5.5.0 build-3252642) / 5.5u3d on Windows (5.5.0 build-3721164) / 6.0.0b (6.0.0 build-2776510) or later.
Note that vCenter Server Windows releases 5.0 u3e, 5.1 u3b, and 5.5 u3b additionally require KB 2144428 to be applied. See VMSA-2015-0007 for details. Alternatively, versions 5.1 and 5.5 on Windows may be fixed with their respective u3d builds.
Furthermore, remote and local exploitation of this vulnerability is feasible on vCenter Server 6.0 and 6.0.0a for Windows. Remote exploitation is not feasible on vCenter Server 6.0.0b (and above) for Windows but local exploitation is. The local exploitation vulnerability can be resolved by applying the steps of KB 2145343 to vCenter Server version 6.0.0b (and above) for Windows.