VMware vCenter Server 5.0.x < 5.0u3e / 5.1.x < 5.1u3b / 5.5.x < 5.5u3 (Linux) / 5.5.x < 5.5u3b (Windows) / 6.0.x < 6.0.0b JMX Deserialization RCE (VMSA-2016-0005)

critical Nessus Plugin ID 91322
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

A virtualization management application installed on the remote host is affected by a remote code execution vulnerability.

Description

The version of VMware vCenter Server installed on the remote host is 5.0.x prior to 5.0u3e, 5.1.x prior to 5.1u3b, 5.5.x prior to 5.5u3 (Linux), 5.5.x prior to 5.5u3b (Windows), or 6.0.x prior to 6.0.0b.
It is, therefore, affected by a flaw in Oracle JMX when deserializing authentication credentials. An unauthenticated, remote attacker can exploit this to execute arbitrary code.

Solution

Upgrade to VMware vCenter Server version 5.0u3e (5.0.0 build-3073236) / 5.1u3b on Linux or Windows (5.1.0 build-3070521) / 5.1u3d on Windows (5.1.0 build-3814779) / 5.5u3 on Linux (5.5.0 build-3000241) / 5.5u3b on Windows (5.5.0 build-3252642) / 5.5u3d on Windows (5.5.0 build-3721164) / 6.0.0b (6.0.0 build-2776510) or later.

Note that vCenter Server Windows releases 5.0 u3e, 5.1 u3b, and 5.5 u3b additionally require KB 2144428 to be applied. See VMSA-2015-0007 for details. Alternatively, versions 5.1 and 5.5 on Windows may be fixed with their respective u3d builds.

Furthermore, remote and local exploitation of this vulnerability is feasible on vCenter Server 6.0 and 6.0.0a for Windows. Remote exploitation is not feasible on vCenter Server 6.0.0b (and above) for Windows but local exploitation is. The local exploitation vulnerability can be resolved by applying the steps of KB 2145343 to vCenter Server version 6.0.0b (and above) for Windows.

See Also

https://www.vmware.com/security/advisories/VMSA-2016-0005.html

Plugin Details

Severity: Critical

ID: 91322

File Name: vmware_vcenter_vmsa-2016-0005.nasl

Version: 1.5

Type: remote

Family: Misc.

Published: 5/25/2016

Updated: 11/19/2019

Dependencies: find_service.nasl, os_fingerprint.nasl, vmware_vcenter_detect.nbin

Risk Information

CVSS Score Source: CVE-2016-3427

VPR

Risk Factor: High

Score: 8.1

CVSS v2

Risk Factor: Critical

Base Score: 10

Temporal Score: 7.4

Vector: AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: Critical

Base Score: 9

Temporal Score: 7.8

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:vmware:vcenter_server

Required KB Items: Host/VMware/vCenter, Host/VMware/version, Host/VMware/release

Exploit Ease: No known exploits are available

Patch Publication Date: 5/17/2016

Vulnerability Publication Date: 4/19/2016

Reference Information

CVE: CVE-2016-3427

VMSA: 2016-0005